Bug report #12091

QGIS Server: valueRelation not correctly resolved in GetFeatureInfo response

Added by Andreas Neumann almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:QGIS Server
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20287

Description

It looks like in current QGIS master, QGIS server, does not correctly replace the numeric code of a value relation widget with the corresponding text. This used to work in an older version of QGIS server. Seems to be a regression.

In the attached demo-project there is a value relation defined on layer "Langsamverkehrszonen", attribute "status_t30_begegnungszone". It is properly displayed in QGIS desktop, but QGIS server just delives the numeric code. It should deliver the text from the value relation.

getFeature_expression_qgis_server_problem.zip - Sample project demonstrating the issue (337 KB) Andreas Neumann, 2015-01-29 02:55 AM

Associated revisions

Revision 1e9774fd
Added by Jürgen Fischer almost 5 years ago

qgis server fixes:
  • support edit types based on edit widgets (adds qgis_gui dependency; fixes #12091)
  • show null values (fixes #12114)
  • only quote non-numeric non-null values in feature info
  • fix crash on exit
  • remove obsolete parser method and debug output

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Affected QGIS version changed from 2.6.0 to master
  • Priority changed from High to Severe/Regression

#2 Updated by Jürgen Fischer almost 5 years ago

  • Assignee changed from Marco Hugentobler to Jürgen Fischer

#3 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF