Bug report #12028

Composer issue with object(s) selection(s) from map canvas

Added by Sébastien Gibert almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:20231

Description

In version 2.0 you could select object from canevas and print it directly from composer. Since 2.0 you can't do it anymore.

And if you could deal with many selection and affect a color/frame... of your choice to it... it would be great

Thks for the guys who are going to fix it!

selection.jpg (340 KB) Sébastien Gibert, 2015-01-21 05:31 AM

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Target version deleted (Version 2.8)
  • Priority changed from High to Normal
  • Status changed from Open to Feedback
  • Subject changed from Composer issue with object(s) selection(s) from map canevas to Composer issue with object(s) selection(s) from map canvas

Hi,

I'm not aware of anything that was possible to do in the qgis 2.0 composer and that is not in later versions.

Could you please explain a little more in detail (with steps on how replicate) this issue?

thanks

#2 Updated by Sébastien Gibert almost 7 years ago

Hi and thanks for your answer.

In version 2.0, I used to select an object from map canvas with the selected tool. Then i just print from any composer and my selection was print also. You didn't have any action to do. it just print the selection as it was on the screen.

I joined a screen capture of my composer to this message. The blue pipe is my selection.

I try to make it clear but i m not at ease trying to explain these things in english... I know alternative way to get a print like this but this is the fastest and the easiest.

#3 Updated by Matthias Kuhn almost 7 years ago

  • Status changed from Feedback to Closed
  • Resolution set to wontfix

I don't know when exactly it has been removed, but I doubt that this will be re-included for the reason that it's mostly not what's expected (for instance, any text processor, graphics software, browser etc. uses selection only on screen for editing and does not print it).

For this reason, $isselected has recently been introduced in the Expressions+ plugin. This exposes the whole powerful possibilities offered by the QGIS styling engine and lets you connect it to your current selection.

Also available in: Atom PDF