Bug report #11948

OGR provider: editing enabled when the file cannot be opened in write mode

Added by Hugo Mercier almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20156

Description

The OGR data provider returns editing capabilities if the underlying format supports it, and even if the file failed to be opened in write mode.
This gives a strange behaviour where the layer seems to be editable, but cannot be saved in the end.
See the joined .mif example

test_mif.mif (6.5 KB) Hugo Mercier, 2015-01-05 03:03 AM

test_mif.mid (88 Bytes) Hugo Mercier, 2015-01-05 03:03 AM

History

#1 Updated by Hugo Mercier almost 7 years ago

See PR #1752 for a possible fix

#2 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

merged in f5b10ba

Also available in: Atom PDF