Bug report #11927

Composer compatibility issues between 2.4 and 2.6

Added by Bogdan Hlevca almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20136

Description

I have a project created in 2.4 and when I open the Composer the frame is not displayed. Moreover, the coordinates around the frame also do not appear and whatever I tried to do did not help.

There is either a incompatibility between 2.4 and 2.6 at composer level or there is a bug. I create my versions from GIT and just switching the checkout version produces this error. According to some reports that can be read at the link below the issue appears for some and not for others. This will rather point to a incompatibility, maybe deleting/renaming the ".qgis2" director could help, but I would lose all my history and settings. I will have to check that, but at the time I am under time pressure to fix some maps and for the time being I reverted to 2.4.

There is definitely a problem but we need to find what that is.
There are other issues with the composer most likely due to the same incompatibility. For example :
1) the map is set by default to Rectangle
2) after changing it to Render the map takes minutes to appear

[[https://gis.stackexchange.com/questions/120887/zebra-grid-is-not-displayed-in-map-composer/127740#127740]]

History

#1 Updated by Bogdan Hlevca almost 6 years ago

Sorry for the duplicate. Closing

#2 Updated by Bogdan Hlevca almost 6 years ago

Sorry for the duplicate. Closing

#3 Updated by Bogdan Hlevca almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF