Bug report #1192

Labels incorrectly rendered in OS X 10.5.4 (QGIS 0.11.0)

Added by rpeskin - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tom Elwertowski
Category:-
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11252

Description

In QGIS 0.11.0 running under OS X 10.5.4, Labels (Display labels) are incorrectly rendered. All or major parts of the labels do not appear. Labels render correctly in QGIS 0.10.0.

History

#1 Updated by Ollie O'Brien - about 12 years ago

Confirmed, I see this too, also under Mac OS X 10.5.4 and QGIS 0.11.0.

It appears that only the part of the label below and to the right of the point appears - so, if the alignment of the label is set to bottom-right, it appears OK. If it is set to the bottom or right, it is truncated. In any other orientation, it does not appear at all.

#2 Updated by Tom Elwertowski about 12 years ago

This looks like the Qt 4.4.0 problem reported by John Tull in the QGIS Developer List on 7/9/08. John also reported on 8/5/08 that this has been fixed in Qt 4.4.1. (Qt 4.3.4 was current when QGIS 0.10.0 was released and 4.4.0 was current for 0.11.0)

It is probably specific to certain video cards. I have a MacBookPro/GeForce 8600M GT 10.5.4 and a MacG4/ATY Rage128Pro 10.4.11 and did not see the problem using Qt 4.4.0 on either.

#3 Updated by Tom Elwertowski about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF