Bug report #11911

rotation: inverted polygon renderer broken with non-zero rotation value

Added by Mathieu Pellerin - nIRV over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Sandro Santilli
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20121

Description

Inverted polygon renderer is broken when a non-zero rotation value is used. See the attached screenshots which should do a good job at showing the problem.

proper-rendering-no_rotation.png.jpg (127 KB) Mathieu Pellerin - nIRV, 2014-12-23 02:18 AM

broken-rendering-10_degree_rotation.png.jpg (136 KB) Mathieu Pellerin - nIRV, 2014-12-23 02:18 AM

History

#1 Updated by Sandro Santilli over 4 years ago

How do you enable the inverted polygon renderer ?

#2 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Future Release - High Priority to Version 2.8
  • Priority changed from Normal to Severe/Regression

#3 Updated by Sandro Santilli over 4 years ago

  • Status changed from Open to Feedback

I need a way to replicate this, attach a style file maybe and/or give instructions on how to enable the "inverted polygon renderer"

#4 Updated by Mathieu Pellerin - nIRV over 4 years ago

  • Status changed from Feedback to Closed

I can't reproduce the above captured bug with a simplified inverted renderer symbology project. Closing this until I figure out what are the requirements to reproduce the issue.

Sandro, the inverted renderer is a polygon-specific renderer, you can select it using the drop-down renderer list (where you have simple, classified, categorized, rule-based renderers).

Also available in: Atom PDF