Bug report #11910

in case of rotation zoom by rectangle shows artifacts

Added by zicke - almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:Sandro Santilli
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20120

Description

The zooming rectangle is broken. See attached image.

rotated.png (172 KB) zicke -, 2014-12-23 02:04 AM

rubberband_rotation.patch Magnifier (3.29 KB) Sandro Santilli, 2014-12-30 08:07 AM


Related issues

Duplicated by QGIS Application - Bug report #12601: QgsMapCanvasItem not position properly if map is rotated Closed 2015-04-18

History

#1 Updated by Sandro Santilli almost 6 years ago

Please add "in case of rotation" in the title, as that's the condition for the artifacts to show up (it's important to clearly mark this not as a regression)

#2 Updated by Giovanni Manghi almost 6 years ago

  • Subject changed from zoom by rectangle shows artifacts to in case of rotation zoom by rectangle shows artifacts

Sandro Santilli wrote:

Please add "in case of rotation" in the title, as that's the condition for the artifacts to show up (it's important to clearly mark this not as a regression)

it is not a regression, but blockers are also new features that do not work as expected. In this case I'm not sure what to do will all this issues about the rotation or caused by, as there is much discussion about it. To me they should be all fixed in time for 2.8 (so they all should be blockers).

#3 Updated by Sandro Santilli almost 6 years ago

I've a fix for this issue, but it builds on the workaround to limitation of QgsMapCanvasItem::setRect which was reported in #11909
The patch is attached for review.

\\cc Martin Dobias

#4 Updated by Sandro Santilli almost 6 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF