Bug report #1184

Cannot reset field settings to <off> in layers properties

Added by Marco Pasetti - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11244

Description

In the layer property window I set Rotation and Area scale fields and then press OK.
After that, when I open the property window again, and I try to set one of them to <off> again, I cannot do it, because I can only select one of the fields of the related vector layer database.

Sample imagine attacched

Marco

Associated revisions

Revision e86fe1c7
Added by Jürgen Fischer about 12 years ago

fix #1184

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 7cc88b1e
Added by Jürgen Fischer about 12 years ago

fix #1184

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Marco Pasetti - about 12 years ago

Replying to marcopx:

In the layer property window I set Rotation and Artea scale fields and then press OK.
After that, when I open the property window again, and I try to set one of them to <off> again, I cannot do it, because I can only select one of the fields of the related vector layer database.

Sample imagine attacched

Marco

The file size limit is too small, so I uploaded the image here: http://www.webalice.it/marco.pasetti/temp/qgis-bugs/bug001.png

#2 Updated by Maciej Sieczka - about 12 years ago

Confirmed on Debian. Sample attached.

1. Take the attached shapefile.

2. In layer properties, set scale or rotation to some field, press OK.

3. Re-enter layer properties - you can't disable what you set in step 2.

#3 Updated by Tim Sutton about 12 years ago

  • Status changed from Open to In Progress

Note jpg images are generally smaller and attachable.

#4 Updated by Jürgen Fischer about 12 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

fixed in

#5 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF