Bug report #11815

Feature highlight from Identify features misplaced on rotation

Added by Sandro Santilli almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Sandro Santilli
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20038

Description

The rendered feature highlight from identify features gets misplaced on map rotation.

rotation_selection.mp4 (1.58 MB) Giovanni Manghi, 2014-12-30 01:27 AM


Related issues

Related to QGIS Application - Bug report #11817: Grid decoration meaningless with rotated map Closed 2014-12-09

History

#1 Updated by Sandro Santilli almost 5 years ago

Note that the feature selection highlight (from select features tool) renders correctly (in yellow), so this is specific to identify feature (dunno what's the difference in rendering)

#2 Updated by Giovanni Manghi over 4 years ago

Sandro Santilli wrote:

Note that the feature selection highlight (from select features tool) renders correctly (in yellow), so this is specific to identify feature (dunno what's the difference in rendering)

it renders correctly, when it works. See the attached screencast that shows that the selection tool works, but not in a reliable way (every time the mouse stops over a polygon a click is given to try make a selection).

#3 Updated by Sandro Santilli over 4 years ago

Giovanni please file another ticket if the selection tool does not work correctly.
My observation was about the highlighting (due to selection) retaining correct position as the map was rotated.
This ticket is about the highlighting (due to identify feature) NOT retaining it.

#4 Updated by Sandro Santilli over 4 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Fixed with commit dee9c462e9b0f939c1d656b7e2d21be7421b7f7a

Also available in: Atom PDF