Bug report #11788

core.so: undefined symbol: _ZTI18QgsHeatmapRenderer

Added by Mikhail Tchernychev almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Ubuntu 14.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20015

Description

Hi,

I followed instruction and got master version of QGIS. Everything compiles fine, but when I start I got message:
Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
File "", line 1, in
File "/home/misha/opt/qgis-dev/share/qgis/python/qgis/__init__.py", line 36, in
from qgis.core import QgsFeature, QgsGeometry
File "/home/misha/opt/qgis-dev/share/qgis/python/qgis/core/__init__.py", line 2, in
from qgis._core import *
ImportError: /home/misha/opt/qgis-dev/share/qgis/python/qgis/_core.so: undefined symbol: _ZTI18QgsHeatmapRenderer

Python version:
2.7.6 (default, Mar 22 2014, 23:03:14)
[GCC 4.8.2]

QGIS version:
2.7.0-Master 'Master', exported

Python path:
['/home/misha/opt/qgis-dev/share/qgis/python', u'/home/misha/.qgis2/python', u'/home/misha/.qgis2/python/plugins', '/home/misha/opt/qgis-dev/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-i386-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode']

I tried to remove .qgis, .config/QGIS but everything is the same.

It seems _core library did not get some feature compiled.

Thank you
Mikhail

History

#1 Updated by Mikhail Tchernychev almost 6 years ago

  • Status changed from Open to Closed

Sorry, this was fixed by defining LD_LIBRARY_PATH pointing to the lib folder
like

export LD_LIBRARY_PATH=/home/misha/opt/qgis-dev/lib

Seem working now :)

Thank you
Mikhai

Also available in: Atom PDF