Bug report #11645

WFS bounding box issue

Added by Neil Benny about 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:19898

Description

When loading a WFS into QGIS uncached the bounding box seems to expand when the map is panned.

I view an area on an initial view and can see the features loaded. I then pan directly to the northeast and the new features are loaded along with the old features. Features to the north and east of the original area are also loaded even though they are not and have not been within the viewing extent (see diagram).

This slows down and causes issues with feature limits.

The problem can be replicated using the following WFS: http://ogc.bgs.ac.uk/cgi-bin/BGS_Bedrock_and_Superficial_Geology/wms?

It can be replicated:

zoom in to a bounding box: -3.90,55.97 : -3.16,56.46 (EPSG 4326)
Add the BGS lithography lay 1:625k untick the cached box using the WFS tool
once data is loaded pan to the northwest to a whole new area.
Select all features
Copy features
Paste as memory layer

You will see that the features cover an area much wider than the two view extents.

I have tested this on previous versions 2.2 - 2.6 and the bug is present

greenbug_schematic.jpg - schematic diagram showing issue (18.3 KB) Neil Benny, 2014-11-14 06:49 AM

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Since the report the wfs client has been overhauled, and options changed/removed. The available "only request features overlapping..." works as expected now. Please reopen if necessary.

Also available in: Atom PDF