Bug report #11643

SRID/ Primary key not populating with "Only look in meta data table" unchecked

Added by Jonathan Moules almost 6 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/Oracle
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:19896

Description

To replicate:
- Connect to table with these checkboxes selected:
--"Only look for users tables", and "only look in meta data table".

I get 23 different selectable tables, all have a SRID correctly determined.

=============

- Now do the same again but use these options only:
- "Only look for users tables"

- I get NO results with SRID correctly determined. They all say "Enter SRID".

Problem is MDSYS.SDO_GEOM_METADATA_TABLE does have SRID's for all those tables. So actual metadata is being ignored when "Only look in meta data table" is disabled. Surely it should start by searching the metadata table getting all pertinent data, then look for all tables that are not in there if the checkbox is disabled?

QGIS 2.6

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Jürgen Fischer about 3 years ago

  • Assignee deleted (Jürgen Fischer)

#3 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF