Bug report #11609

Graduated styling of vector layer neglects fields from joined tables

Added by Peter Tarne over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.6.0 Regression?:No
Operating System:Mac Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19865

Description

I have joined a vector layer with CSV table values. The attribute table of the joined layer shows all fields as expected.
However, when I try to apply graduated styling QGIS only offers the attribute fields of the 'original' vector layer before joining attributes as basis for styling.

test.dbf (513 KB) Peter Tarne, 2014-11-10 08:51 AM

attritube_table.png - The attribute table of the joined vector layer (on the right is column 'TOT DMG' which I would like to use for graduated styling) (283 KB) Peter Tarne, 2014-11-10 08:57 AM

Attributes_for_graduated_styling.png - The only attributes QGIS offers me for graduated styling are the 'original ones' from TM World Borders (113 KB) Peter Tarne, 2014-11-10 08:57 AM

History

#1 Updated by Peter Tarne over 5 years ago

Hm, my SHP-file was too large for upload... so I attach screenshots...

#2 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

this is because csv columns are always treated as text (that cannot be used by the graduated renderer), unless otherwise specified by using a csvt file.

http://anitagraser.com/2011/03/07/how-to-specify-data-types-of-csv-columns-for-use-in-qgis/

cheers!

Also available in: Atom PDF