Feature request #1160

cmake 2.6 developer warnings

Added by John Tull over 12 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Build/Install
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11220

Description

I'm not sure if this is occurring due to changes in trunk, or if it is from switching to cmake 2.6. I suspect the latter. This is not affecting my ability to build the source, or in qgis use.

-- Found Proj: /Library/Frameworks/PROJ.framework/unix/lib/libproj.dylib
-- Found Sqlite3: /Library/Frameworks/SQLite3.framework/unix/lib/libsqlite3.dylib
-- Found GEOS: /Library/Frameworks/GEOS.framework/unix/lib/libgeos.dylib
-- Found GDAL: /Library/Frameworks/GDAL.framework/Versions/1.5/unix/lib/libgdal.dylib
-- Found PostgreSQL: /usr/local/pgsql/lib/libpq.dylib
-- Found Expat: /usr/lib/libexpat.dylib
-- Using GSL from /usr/local
-- Found GRASS: /Applications/GRASS-6.3.app/Contents/MacOS (6.3.0)
-- Python libraries found
-- Python bindings enabled
CMake Warning (dev) at CMakeLists.txt:257 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at CMakeLists.txt:258 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at CMakeLists.txt:259 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at src/providers/grass/CMakeLists.txt:1 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at src/plugins/grass/CMakeLists.txt:4 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at src/plugins/grass/CMakeLists.txt:21 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at src/python/CMakeLists.txt:9 (ADD_DEFINITIONS):
Policy CMP0005 is not set: Preprocessor definition values are now escaped
automatically. Run "cmake --help-policy CMP0005" for policy details. Use
the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring done
-- Generating done
-- Build files have been written to: /path

History

#1 Updated by Giovanni Manghi over 11 years ago

Hi,

is this ticket outdated?

#2 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I guess this is really outdated, but please reopen if I'm wrong.

Also available in: Atom PDF