Bug report #11564

problem when copy data dbmanager table using ctrl-c

Added by Luca Lanteri about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:2.6.0 Regression?:No
Operating System:ubuntu, win7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19828

Description

1) SELECT * FROM table
2) select all record in table by click the upper-left corner of table
3) press ctrl-C

this error occurs:

An error has occured while executing Python code:
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/db_manager/dlg_sql_window.py", line 282, in copySelectedResults
text += "\
" + model.rowToString( idx.row(), "\\t" )
File "/usr/share/qgis/python/plugins/db_manager/db_plugins/data_model.py", line 41, in rowToString
text += u"%s" % self.getData(row, col) + sep
UnicodeDecodeError: 'ascii' codec can't decode byte 0x80 in position 7: ordinal not in range(128)

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #10051

Also available in: Atom PDF