Bug report #11551

SERVICE parameter is NOT mandatory @ GetMap on WMS 1.3.0

Added by Marco Lechner over 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19821

Description

Refering to OGC WMS spec 1.3.0 (chapter 7.3.2) the SERVICE parameter is not mandatory (M) for GetMap REQUESTs. It is only M for GetCapabilities. QGIS returns an Exception when processing a GetMap request without SERVICE parameter. This brakes OGC compliance! Compare QGIS Server with reference implementation and testcase of http://cite.opengeospatial.org

Try as long as it is available:
http://176.221.43.85/cgi-bin/qgis_mapserv.fcgi?MAP=/data/ogc13.qgs&VERSION=1.3.0&REQUEST=GetMap&LAYERS=cite%3ABasicPolygons&STYLES=&CRS=CRS:84&BBOX=-1,-1,1,1&WIDTH=300&HEIGHT=300&FORMAT=image%2Fjpeg

Btw. GetFeatureInfo seems to be affected by this as well.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Target version deleted (Version 2.6)

#2 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

fixed in 3552b83

Also available in: Atom PDF