Bug report #11456

canvas do not refresh anymore after adding a new feature in a vector layer

Added by Giovanni Manghi about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19732

Description

this causes the new feature to not show after ending its edition.

caused by

#5e54912565930019bac14908658263ef92ee0426

Associated revisions

Revision ba8a60f6
Added by Martin Dobias about 5 years ago

Fix #11456 (canvas not refreshed anymore after adding a new feature)

Resorted to a "minimalist" fix - other solutions would potentially break
even more stuff. The handling of non-modal dialogs for add/edit feature
attributes + handling of isModified() should be addressed at some point.

History

#1 Updated by Martin Dobias about 5 years ago

  • Assignee set to Martin Dobias

#2 Updated by Martin Dobias about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF