Bug report #11444

Min/Max values are not applied for number parameter

Added by Tim Sutton almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19720

Description

When I create a new modeller input (number), the min max values I enter are forgotten when I reopen the parameters definition.

Using QGIS eb998de

out-2.ogv (1.86 MB) Tim Sutton, 2014-10-20 01:26 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Operating System deleted (Ubuntu)
  • Affected QGIS version changed from 2.4.0 to master

confirmed also on other platforms.

#2 Updated by Victor Olaya almost 5 years ago

  • Status changed from Open to Closed

fixed in 18e9fba08b4def90aabed33ad240cbbd3cb4c12a

#3 Updated by Tim Sutton almost 5 years ago

Victor Olaya wrote:

fixed in 18e9fba08b4def90aabed33ad240cbbd3cb4c12a

Thanks Victor!

Regards

Tim

#4 Updated by Tim Sutton almost 5 years ago

  • Status changed from Closed to Reopened

Tim Sutton wrote:

Victor Olaya wrote:

fixed in 18e9fba08b4def90aabed33ad240cbbd3cb4c12a

Thanks Victor!

Regards

Tim

Hi

Hmm I just tested again and the min max still arent being remembered for me (running d2f89c5a2042747e36f4f9cd0370cec2da27d1ca here).

To replicate:

- add number to modeller
- set min value e.g. 1
- set max valie e.g. 200
- set default e.g.78
- close parameter window
- reopen and the min max are gone

Regards

Tim

#5 Updated by Victor Olaya almost 5 years ago

weird. IT is working here (actually i tried the same numbers)

Are you editing the parameter you added (which now cannot be done double clicking), or you mean you are adding a new number parameter and it does not remember the latest value. I have only implemented the first case, for remembering the values of a parameter that exists and is been edited

#6 Updated by Tim Sutton almost 5 years ago

Victor Olaya wrote:

weird. IT is working here (actually i tried the same numbers)

Are you editing the parameter you added (which now cannot be done double clicking), or you mean you are adding a new number parameter and it does not remember the latest value. I have only implemented the first case, for remembering the values of a parameter that exists and is been edited

Hi

I tested here on my work machine. It still gives the same issue (built against d2f89c5). See attached screencast to see exactly what I am doing.

Regards

Tim

#7 Updated by Tim Sutton almost 5 years ago

Tim Sutton wrote:

Victor Olaya wrote:

weird. IT is working here (actually i tried the same numbers)

Are you editing the parameter you added (which now cannot be done double clicking), or you mean you are adding a new number parameter and it does not remember the latest value. I have only implemented the first case, for remembering the values of a parameter that exists and is been edited

Hi

I tested here on my work machine. It still gives the same issue (built against d2f89c5). See attached screencast to see exactly what I am doing.

Regards

Tim

I'm actually wondering if I am getting the right version of processing in my pythonpath - double clicking still works for me to edit properties too.

I'll poke around a bit further.

Regards

Tim

#8 Updated by Giovanni Manghi almost 5 years ago

Tim Sutton wrote:

Tim Sutton wrote:

Victor Olaya wrote:

weird. IT is working here (actually i tried the same numbers)

Are you editing the parameter you added (which now cannot be done double clicking), or you mean you are adding a new number parameter and it does not remember the latest value. I have only implemented the first case, for remembering the values of a parameter that exists and is been edited

Hi

I tested here on my work machine. It still gives the same issue (built against d2f89c5). See attached screencast to see exactly what I am doing.

Regards

Tim

I'm actually wondering if I am getting the right version of processing in my pythonpath - double clicking still works for me to edit properties too.

I'll poke around a bit further.

Regards

Tim

do you have any "processing" folder inside ~/.qgis2/pyhton/plugins ?

if yes then you have an old processing version masking the new one that comes with master. Delete that folder.

#9 Updated by Tim Sutton almost 5 years ago

  • Status changed from Reopened to Closed

Giovanni Manghi wrote:

Tim Sutton wrote:

Tim Sutton wrote:

Victor Olaya wrote:

weird. IT is working here (actually i tried the same numbers)

Are you editing the parameter you added (which now cannot be done double clicking), or you mean you are adding a new number parameter and it does not remember the latest value. I have only implemented the first case, for remembering the values of a parameter that exists and is been edited

Hi

I tested here on my work machine. It still gives the same issue (built against d2f89c5). See attached screencast to see exactly what I am doing.

Regards

Tim

I'm actually wondering if I am getting the right version of processing in my pythonpath - double clicking still works for me to edit properties too.

I'll poke around a bit further.

Regards

Tim

do you have any "processing" folder inside ~/.qgis2/pyhton/plugins ?

if yes then you have an old processing version masking the new one that comes with master. Delete that folder.

Ah yes (facepalming here) that was it. Sorry for the noise.

Regards

Tim

Also available in: Atom PDF