Bug report #11420

Quick calculation bar updates wrong column when using aliases

Added by Alexandre Neto almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:19697

Description

The quick calculation bar does not work as expected when trying to update a field that has an alias set.
Instead of updating the selected column, it updates the first column in the table.

This affects both 2.4 and master.

This can lead easily to data loss if the user does not confirm the update.

To reproduce the problem add a layer (I have tried with shapefiles and postgis table), and try to update one of the fields (not the first one) using the quick calculation bar. Now Go to the layer properties > fields and set an alias for the same field.

Going back to the attribute table, you will see that the field selection combo box as changed (as it should) and trying to update the field will no longer work.

Associated revisions

Revision d11597a5
Added by Martin Dobias almost 5 years ago

Fix #11420 (Quick calculation bar updates wrong column when using aliases)

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Subject changed from Not possible to use quick calculation bar to update a field that uses an alias to Quick calculation bar updates wrong column when using aliases
  • Priority changed from High to Severe/Regression
  • Crashes QGIS or corrupts data changed from No to Yes

I would set this as a blocker, because it causes a severe data corruption/lost. Feel free to downgrade it.

#2 Updated by Jürgen Fischer almost 5 years ago

  • Assignee set to Jürgen Fischer

#3 Updated by Martin Dobias almost 5 years ago

  • Status changed from Open to Closed

#4 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Closed to In Progress
  • Assignee changed from Jürgen Fischer to Martin Dobias

#5 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from In Progress to Closed

#6 Updated by Martin Dobias almost 5 years ago

Uhhhh sorry Jürgen

Also available in: Atom PDF