Bug report #11398

Buggy/unreadable polygons created by functions splitting/fill ring/Reshape features...

Added by Christoph Moebus about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:2.4.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:19680

Description

While trying to edit a simple polygon shape file all the used functions splitting/fill ring/Reshape features create a buggy shape-file that is not readable by any other GIS-enabled programm correctly.
The only way to create a correct polygon shape file with the edits is to use the command "Save as" with creating a new file!

The bug is easy to reproduce -> open the Shapefile in "Test501_before_editing.zip" and use one of the above mentioned features (e. g. "Split features") to split the polygon and try to read it with a different GIS-enabled programm (not QGIS!) and see the bug (= e. g. "Test501_after_editing.zip").

Now save the polygon shape file as a new file with a new name and everything is fine "Test502_after_saving.zip"

I did not try all the other polygon editing features, but they probably create the same bug.

Test501_after_editing.zip - Example polygon shapefile after editing (2.09 KB) Christoph Moebus, 2014-10-13 06:43 AM

Test501_before_editing.zip - Example polygon shapefile before editing (1.73 KB) Christoph Moebus, 2014-10-13 06:43 AM

Test502_after_saving.zip - Example polygon shapefile after saving as a new file (1.16 KB) Christoph Moebus, 2014-10-13 06:43 AM

test_issue_1139.zip (7.01 KB) andre mano, 2014-10-14 08:50 AM

test_issue_1139_redrawn.zip (4.17 KB) Christoph Moebus, 2014-10-14 09:22 AM

Manifold_View.jpg (151 KB) Christoph Moebus, 2014-10-14 09:31 AM

GMS_view.jpg (100 KB) Christoph Moebus, 2014-10-14 09:31 AM

Manifold_Table.jpg (87.8 KB) Christoph Moebus, 2014-10-14 09:31 AM

GMS_error.jpg (7.06 KB) Christoph Moebus, 2014-10-14 09:31 AM

GMS_table.jpg (18.4 KB) Christoph Moebus, 2014-10-14 09:31 AM

test_issue_1139__2_.zip (7.23 KB) andre mano, 2014-10-16 05:52 AM


Related issues

Related to QGIS Application - Bug report #11007: Deleted/edited features within SHAPEFILE are still recogn... Closed 2014-08-05
Related to QGIS Application - Bug report #11296: Deleting shapes in shapefiles does not work Closed 2014-09-30
Related to QGIS Application - Bug report #8822: OGR: Repack in running session Closed 2013-10-11

Associated revisions

Revision 7d7cdcd3
Added by Matthias Kuhn over 4 years ago

Repack shapefiles when saving after deleting features

  • QgsVectorDataProvider::dataChanged() will be emitted
  • QgsVectorLayer::dataChanged() will be emitted
  • Clears QgsVectorLayerCache
  • Reloads the attribute table
  • Clears the selection

Looking forward to people complaining about their lost selection...

Fix #10560
Fix #11989
Refs #8317
Refs #8822
Refs #10483
Refs #11007
Refs #7540
Refs #11398
Refs #11296

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

Hi, we need more details: what other software did you tested? What error messages did you get? doing what operation?

I just tested ArcGIS 10.* and gvSIG with your Test501_after_editing.zip sample and I have seen no problems whatsoever.

#2 Updated by andre mano about 5 years ago

I just tested now with a fresh polygon created (and then splited) in QGIS Master (build b94b44a) and then opened the shapefile in ArcGIS 10.2 without any abnormal behaviour. Attached is the project and shapefile. Could you test this in your computer and see if you can replicate the problem? Probably this is a local issue.

#3 Updated by Christoph Moebus about 5 years ago

Thanks Andre,
the polygon you sent works perfectly fine at my site with the other GIS programms ...

Can you try and add a new column (e. g. decimal number with precission 2), then split the polygon again and post it again?
Because when I did this and tried to load it back in the programm again it did not work (attached file).
I have tested this issue at three different computers at my site and it exists at all of them.

#4 Updated by Christoph Moebus about 5 years ago

@Giovanni (or someone else...):

I have used "Manifold GIS", "GMS" from Aquaveo, "FEFLOW" from DHI-WASY and they all show faults with the polygons edited in QGIS

It looks like, there are still some geometries left from the editing process and only the table (dbf) shows the correct two polygons.
You can see that in the views from Manifold and GMS I attached - there you can click on three "different" polygons, although there only should exist two. This is what you would expect from the table in Manifold (see screenshot). GMS is telling that the records are not consistent (see GMS screenshots)

#5 Updated by Giovanni Manghi about 5 years ago

Christoph Moebus wrote:

@Giovanni (or someone else...):

I have used "Manifold GIS", "GMS" from Aquaveo, "FEFLOW" from DHI-WASY and they all show faults with the polygons edited in QGIS

anything I can freely download and install in my Windows virtual machine? if yes can you provide some link? thanks!

#6 Updated by Christoph Moebus about 5 years ago

Yes, you can download FEFLOW at http://www.feflow.com/download.html?&no_cache=1
and use the free demo licence and you can download GMS also at http://www.aquaveo.com/downloads Unfortuantely there is no free licence for Manifold GIS

#7 Updated by andre mano about 5 years ago

Hi Cristoph,

I did as you said (add a decimal column, split the polygon, open it in ArcGIS 10.2), but still I could not replicate your problem. Everything seems to behave as expected here.

Could you please do a screencast showing how you reproduce the error? Maybe we are not replicating the process as we should. For now what I can say is that as far as ArcGIS is concerned everything is ok.

#8 Updated by Giovanni Manghi about 5 years ago

andre mano wrote:

Hi Cristoph,

I did as you said (add a decimal column, split the polygon, open it in ArcGIS 10.2), but still I could not replicate your problem. Everything seems to behave as expected here.

Could you please do a screencast showing how you reproduce the error? Maybe we are not replicating the process as we should. For now what I can say is that as far as ArcGIS is concerned everything is ok.

André, I can confirm the issue. Actually it seems that this 3 tickets

#11007
#11398
#11296

are all the same. I'm trying to make a few tests and then I'll plan to merge them all in 1.

#9 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

duplicate of #11007

Also available in: Atom PDF