Bug report #11379

3D Multipoint layers not correctly loaded/visualized

Added by Giovanni Allegri about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19667

Description

I've tested this both with a Spatialite layer and a Shapefile (it's attached here).
Only one point is shown.
When exporting the data to a new Shapefile the Z component is lost, and reloading it in QGIS it shows the 4 (2D) points correctly.

points3d.zip (1.16 KB) Giovanni Allegri, 2014-10-10 01:24 AM

History

#1 Updated by Giovanni Allegri about 5 years ago

  • Priority changed from High to Severe/Regression

#2 Updated by Giovanni Allegri about 5 years ago

I've tested on 3D MULTILINESTRINGS and it seems to be ok.

#3 Updated by Giovanni Allegri about 5 years ago

  • Pull Request or Patch supplied changed from No to Yes

Pull request for fixing created https://github.com/qgis/QGIS/pull/1625

#4 Updated by Giovanni Allegri about 5 years ago

  • Target version changed from Future Release - High Priority to Version 2.6

#5 Updated by Giovanni Allegri about 5 years ago

  • Affected QGIS version changed from 2.4.0 to master

#6 Updated by Giovanni Allegri about 5 years ago

  • Resolution set to fixed/implemented

#7 Updated by Giovanni Allegri about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF