Bug report #11355

connecting to database puts the dialog behind QGIS main window

Added by Harrissou Santanna almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Salvatore Larosa
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19646

Description

Launch QGIS Master
Open DB Manager Dialog
Connect to a database.
If your connection succeeds, DB Manager is no longer foreground. You need to search and put it foreground before choosing your data.
It's not really a big issue but I mentionned it as "blocker" because it's not the way it worked before, even in 2.4. It remained foreground till you choose to go back to another dialog. And this behaviour is better IMHO.

Associated revisions

Revision d05b0395
Added by Jürgen Fischer almost 5 years ago

restore active window after requesting credentials (fixes #11355)

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Subject changed from DB Manager : connecting to database puts the dialog behind QGIS main window to connecting to database puts the dialog behind QGIS main window

#2 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF