Bug report #11322

Cannot copy/paste Spatialite features (when using autoincrementing primary key)

Added by Giovanni Manghi almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Data Provider/SpatiaLite
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19618

Description

When using a SL layer with autoincrementing primary key copy/paste of features fails on save:

SQLite error: UNIQUE constraint failed: layename.pkuid

It worked as expected until 2.0.1 (stopped since 2.2).

Associated revisions

Revision 42d915ef
Added by Jürgen Fischer over 5 years ago

skip primary key column when pasting to spatialite layers (fixes #11322)

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF