Bug report #11316

python error when setting output file name in GDAL tools

Added by Giovanni Manghi almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19612

Description

Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/GdalTools/tools/doDEM.py", line 116, in fillOutputFileEdit
self.outputFormat = Utils.fillRasterOutputFormat( lastUsedFilter, outputFile )
File "/usr/share/qgis/python/plugins/GdalTools/tools/GdalTools_utils.py", line 230, in fillRasterOutputFormat
filterName = re.sub('^.*\\] ', '', FileFilter.getFilterName( aFilter ))
File "/usr/share/qgis/python/plugins/GdalTools/tools/GdalTools_utils.py", line 479, in getFilterName
return string.strip(re.sub('\\ \\(.*$', '', aFilter))
File "/usr/lib/python2.7/re.py", line 151, in sub
return _compile(pattern, flags).sub(repl, string, count)
TypeError: expected string or buffer

tested on master on both Linux and Windows

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11275

Also available in: Atom PDF