Bug report #1131

shapefile export of PostGIS layer: field size for integer is too small

Added by Bernhard Ströbl over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11191

Description

Any integer field in a PostGIS table is exported as numeric with 4 digits only in the dbf-file, resulting in a data loss for numbers larger than 9999. The table view in QGIS shows the correct numbers, though.
Defect has been reproduced on Win2K and OpenSuse 10.3, so I assume all platforms are affected. Server is Postgres 8.2.4 with PostGIS 1.2.1.

Associated revisions

Revision 44e3a246
Added by Jürgen Fischer over 12 years ago

fix #1131

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 1dd0f3e8
Added by Jürgen Fischer over 12 years ago

fix #1131

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 92259740
Added by Jürgen Fischer about 11 years ago

postgres & ogr provider update:
- postgres provider: report field width 1 for everything except strings (fixes #1131)
in vector file writer, ogr provider choose field width:
- 255 for strings, when given width is negative or larger.
(was 80 in ogr provider and OGR determined-default for vector file writer).
- 10 for integers, when given width is negative or larger.
- 32 for reals, when given width is negative or larger.

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 793b0918
Added by Jürgen Fischer about 11 years ago

postgres & ogr provider update:
- postgres provider: report field width 1 for everything except strings (fixes #1131)
in vector file writer, ogr provider choose field width:
- 255 for strings, when given width is negative or larger.
(was 80 in ogr provider and OGR determined-default for vector file writer).
- 10 for integers, when given width is negative or larger.
- 32 for reals, when given width is negative or larger.

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 1dd0f3e8 (SVN r8678) by adapting the behaviour of the ogr provider.

#2 Updated by barpasen - about 11 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

#3 Updated by Jürgen Fischer about 11 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

looks like 16b91c6b (SVN r11219) broke this again.
793b0918 (SVN r11465) should fix it.

Also available in: Atom PDF