Bug report #11289

Map Canvas doesn't refresh well with diagrams on vector layer

Added by Harrissou Santanna almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19585

Description

Add a vector layer and open its properties dialog
In Diagrams tab, check "display diagrams" ans set diagrams properties as you want
Press OK. You must get diagrams on your features
uncheck the layer visibility in the TOC and check it back.
You then will see the features in the layer but no diagram will appear.

Any other change you'll do in the TOC resulting in the refreshment of the map canvas (add new layer, show/hide layer...) won't make visible your diagram.

The only way I found to display the diagrams is to change map canvas extent (pan or zoom)

History

#1 Updated by Harrissou Santanna almost 5 years ago

  • Status changed from Open to Closed

This seems to be fixed in Master fbc5f06

Also available in: Atom PDF