Bug report #11256

GRASS r.thin not working

Added by Luiz Andrade over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19556

Description

Every time I try to run a GRASS command I receive the following error: "Oooops! The following output layers could not be open".
Actually the same problem happens with other GRASS commands and even with SAGA commands.

r.thin.bmp (688 KB) Luiz Andrade, 2014-09-23 04:30 AM

parameters.bmp (930 KB) Luiz Andrade, 2014-09-23 04:30 AM

ta28582NOaz.tif - This is the image I'm trying to use. (1.18 MB) Luiz Andrade, 2014-09-23 10:56 AM

History

#1 Updated by Luiz Andrade over 5 years ago

I forgot to mention the OS I'm using. I'm trying to run this both on Windows and Linux. On windows I made the installation using the OSGeo4W installer.

#2 Updated by Luiz Andrade over 5 years ago

I'm uploading here the image I'm trying to use to perform the r.thin.

#3 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to invalid
  • Category set to 94

When using Processing (ex Sextante) is suggested to chenge the options and make the module window stay open after the module run, this way you will be able to see the complete module log.

In this case the problem is that your raster is not georeferenced, this is easy to understand because qgis asks for the CRS when you load it, and there is no world file (or at least you haven't provided it).

The r.thin log then shows a message that helps understand

GRASS_INFO_WARNING(28200,2): G_set_window(): Illegal latitude for North
GRASS_INFO_END(28200,2)

probably because the tools expects the raster to be correctly georeferenced.

#4 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF