Bug report #11227

projections in 2.4.0

Added by Hannah Judge almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.4.0 Regression?:No
Operating System:Chugiak Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:19536

Description

Having trouble projecting into Robinson, or really any projection. My CRS on the fly is enabled. Have tried setting project properties, saving as new shapefile, turning on the fly projection on and off etc. I need natural earth data_110m countries in the robinson projection. Tried a bunch of different projections to see if it was just the robinson one that wasn't working, but I keep getting crazy outputs (see file attached). Help!! Time sensitive.

Screen_Shot_2014-09-18_at_11.29.09_AM.png (113 KB) Hannah Judge, 2014-09-18 11:31 AM

History

#1 Updated by Hannah Judge almost 6 years ago

It worked!! .... for a second. Then I zoomed in and got the rectangles again.

#2 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Open to Feedback

Hi Hannah, have you tried turning simplification (layer properties, rendering) off?

#3 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

If you disable the simplification (in layer properties) then it definitely works ok (while with simplification I see the problem in the attached image). Just tested on qgis master with the cited dataset and projection. Please reopen of necessary.

Also available in: Atom PDF