Bug report #1113

Wrong layer order in generated Mapfile

Added by str238 - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:11173

Description

The order of layers in the generated mapfile don't refer to the order in the QGIS project. I tried if they are ordered according to the order layers have been added into the project, but they are not. The simplest test I made was with one RASTER layer and one PostGIS polygon layer. Raster layer have been above the polygon layer no matter what I tried to do.

History

#1 Updated by Gary Sherman over 12 years ago

Make sure you are using the mapserver exporter shipped with 0.10.0 and not the plugin downloaded from the repository.

#2 Updated by str238 - over 12 years ago

The only thing I did was to install the Windows binary and enable the MapServer Export plugin. You can see the current behavior here http://artegis.cz/demo/qgis/orderBug.htm

#3 Updated by Maciej Sieczka - about 12 years ago

How does the issue look in QGIS 0.11? You can obtain it's Windows installer preview at:

http://gigamaildownload.rossoalice.alice.it/download/download.aspx?AttachmentID=2716cab8-980a-45c8-9e9c-8ff538f973e2&MessageID=4602d09e-2a74-48e1-a167-644cb19b13fb

#4 Updated by Tim Sutton almost 12 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Closing as works for me - tested here on 014fe9a9 (SVN r9485) and works fine on ubuntu 8.10.

#5 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF