Bug report #11128

Edition in attribute table (form view) empties multiline text edit types field content

Added by Michael Douchin about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Edit widget
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19457

Description

A user reported a bug during edition of an attribute table under QGIS2.4.

To reproduce :

  • create a vector layer with one "text" field (for example "foo") and add it in the current project
  • open layer properties / Field tab, and check the "multiline" property of the "Text edit" for the field "foo"
  • create 2 features with some content in the "foo" field
  • save layer session and deactivate edition
  • open attribute table, activate edition, toggle to the Form view
  • click on one of the line in the left panel -> the line label changes into NULL
  • click on another line in the left panel -> same behaviour.
  • go back and select the first line -> the value in the "foo" field has bee completely erased
  • toggle edition off, save -> no more values in the "foo" field.

History

#1 Updated by Matthias Kuhn about 6 years ago

  • Status changed from Open to Feedback

Not reproducible on recent master. Did you try with a nightly?

#2 Updated by Michael Douchin about 6 years ago

  • Target version deleted (Version 2.6)
  • Priority changed from Severe/Regression to Low
  • Status changed from Feedback to Closed

I just tested with last master, and I cannot reproduce the issue. Let's close it !

Sorry for the noise, I should have done it before opening this issue.

Also available in: Atom PDF