Bug report #1106

Unable to edit PostGIS layers with case sensitive attribute names

Added by str238 - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11166

Description

There is no way how to edit data in PostGIS tables using the case sensitive attribute names. The only thing needed to be done to fix this is to enclose each attribute name into the double quotation as the table name already is.

History

#1 Updated by Jürgen Fischer over 12 years ago

Please supply an example table which you can't edit. Following table works for me:

CREATE TABLE "FooBarBaz" (
"MixedCaseId" integer NOT NULL PRIMARY KEY,
"MixedCaseAttribute1" integer,
"MixedCaseAttribute2" character varying,
"I can't imägine ""attribute names"" that qgis doesn't support" double precision
);
SELECT addgeometrycolumn('public','FooBarBaz','MixedCaseGeometryColumn',4326,'LINESTRING',2);

#2 Updated by str238 - over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

You are absolutelly right. Sorry for submitting non-existing bug. I is probably my sleep deficit. I upgraded to the 1.0 just today, so maybe I mixed in some older stuff. Is that enough to mark this bug resolved as: invalid or wontfix ?

#3 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF