Bug report #1102

Digitizing over an image hides image with white mask

Added by nedhorning - over 12 years ago. Updated over 12 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11162

Description

There is a problem when digitizing a polygon on top of a raster image. When digitizing a polygon layer on top of an image the area defined by the bounding box of the polygon verticies (or any point covered by the cursor) becomes an opaque white which hides the underlaying image. This is a problem for us since we are trying to digitize features that can be seen in a satellite image.

After loading the satellite image and doing an enhancement we create a new polygon vector file and place it on top of the raster image. We then make it editable and then start drawing a polygon. As we draw, the image area under the bounding box of the polygon becomes white effectively creating a mask that hides the image. The white mask disappears after the polygon is closed. We can “erase” the white mask by refreshing the screen (using ctrl +R) but it reappears as soon as the cursor is moved. If we move the vector layer under the raster layer then the digitizing works fine with no white mask but after the polygon is finished it cannot be seen since the vector layer is under the raster layer.

History

#1 Updated by Jürgen Fischer over 12 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

same as #1016

Also available in: Atom PDF