Bug report #10993

Virtual fields: if selecting integer as data type, then field shows as decimal

Added by Giovanni Manghi over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Virtual Fields
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19336

Description

Steps:

  • add a virtual field using a geometry function like $area
  • choose "integer" as data type
  • have a look at the table of attributes, values are shown with the max possible of decimals numbers

On the other hand when choosing a decimal data type the number of chosen decimals seems to be respected.


Related issues

Related to QGIS Application - Bug report #11000: QgsExpression target format Closed 2014-08-03

Associated revisions

Revision 7318c730
Added by Matthias Kuhn about 6 years ago

Convert values to target field format

For the field calculator and virtual fields.

Fix #11000
Fix #10995
Fix #10993

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Subject changed from Virtual fields: if selecting integer as data type, then selection is ignored to Virtual fields: if selecting integer as data type, then field shows as decimal

#2 Updated by Giovanni Manghi about 6 years ago

still true on the latest master.

#3 Updated by Matthias Kuhn about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF