Bug report #10988

Date widget default format for older projects is yyyy-mm-dd (instead os yyyy-MM-dd)

Added by Alexandre Neto over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Edit widget
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19331

Description

This is a "papercut bug" caused by the fact that Date widget default format for older projects is set to "yyyy-mm-dd" (notice that mm is actually minutes).

Because of the wrong default format the target fields will show wrong values, and errors might occur when trying to commit changes.

The workaround is to manually change the format to "yyyy-MM-dd".

Associated revisions

Revision bcdd3942
Added by Matthias Kuhn over 5 years ago

Merge pull request #1524 from SrNetoChan/master

Fixed Legacy date widget default format
Fix #10988

History

#1 Updated by Alexandre Neto over 5 years ago

I have created a pull request to fix this issue.

https://github.com/qgis/QGIS/pull/1524

#2 Updated by Matthias Kuhn over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF