Bug report #10986

Batch processing autofill option deletes last filename character

Added by Fernando Rizzato almost 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19329

Description

When using Batch processing with any model to process several files at once, there is an autofill option based on input parameter filenames.
When using this option, the last letter of the input filename is deleted when added to the root filename.
This affects only 2.4 since on 2.2 it works properly.

Error_Batch2.jpg (34.7 KB) Fernando Rizzato, 2014-07-30 06:32 AM

Error_Batch.jpg (266 KB) Fernando Rizzato, 2014-07-30 06:32 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to Severe/Regression
  • Assignee set to Victor Olaya
  • Category set to 94

when fixing this please see also #8511 for a very similar issue.

#2 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

should be fixed with

#953f97707308a441c6d882090dfb43f1c8898995

#3 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF