Bug report #10983

CSV export WKT fails with complex geometries

Added by James McMahon almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:Yes Copied to github as #:19326

Description

When exporting a Vector layer as CSV and choosing to export the geometries as WKT, the application silently truncates any geometry whose text would exceed 8000 characters. This includes the removal of the closing " and happens whether the WKT is long because there are many points or because a multipolygon contains many polygons etc. It is the character limit that is observered. Using 2.4.0 on Windows 7

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

just tested and I can confirm it, but the issue seems to be in gdal/ogr (used by qgis) as from the ogr2ogr command line the result is the same

http://www.gdal.org/drv_csv.html

Please file a ticket on the gdal/ogr bug tracker.

Also available in: Atom PDF