Bug report #10982

Polygon rendering

Added by Lubos Balazovic almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19325

Description

Polygon is not rendered in close view (Zoom In). To reproduce:
1. Load attached vector layer
2. set scale to 1:5000
3. Zoom In or set scale to 1:4400. No polygon is rendered.

Note: Screenshots was taken in 2.2 but bug remains also in 2.4

chybny_polygon.zip - affected polygon sample (2.66 KB) Lubos Balazovic, 2014-07-30 02:05 AM

scr01.jpg (77.5 KB) Lubos Balazovic, 2014-07-30 02:05 AM

scr02.jpg (69.2 KB) Lubos Balazovic, 2014-07-30 02:05 AM

clean.dbf.zip (2.81 KB) Giovanni Manghi, 2014-07-30 03:48 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed
  • File clean.dbf.zip added

The attached vector has a serious error in it

0,ring 1 with less than four points
0,Geometry has 1 errors.

this seems the cause and makes impossible to edit the polygon, to select it, etc. Seems anyway an edge case.

Clean it with whaterver tool you prefer (v.clean, the libwgeom plugin, etc.) and you will get a correct vector (attached).

#2 Updated by Lubos Balazovic almost 6 years ago

OK - these errors could by resolved by external tools but QGIS should give some warning, that data contains errors - if data stop working only in special scale it is very confusing.

#3 Updated by Giovanni Manghi almost 6 years ago

Lubos Balazovic wrote:

OK - these errors could by resolved by external tools but QGIS should give some warning, that data contains errors - if data stop working only in special scale it is very confusing.

the tools to check for geometries gives you a cleat hint. So after that usually the user can select the problem and visually have a look at it (and eventually fix it by hand). In this case the error was so weird that the polygon wasn't editable with the node tool (and selecting with the node tool qgis makes a validation and shows the results in the status bar), nor was possible to select it. Never seen anything like that. Said that, the tools to fix even beast like this are available in QGIS, in the Processing toolbox.

Also available in: Atom PDF