Bug report #10957

Digitising & snaps

Added by Jakub Kosik about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:19305

Description

I've started work on big project with digitising in QGIS, and found some bugs when snapping:
1. When I try to move poligon or few polygons (red-line - dig1.png), snapping to same layer - sometimes cretes new vertex instead move (dig2.png);
2. When I move vertex and snap to semi-transparent or black-line polygon layer I got effct: dig3.png - new vertex is crated on far, far away random polygon from edited layer and snapped together.

Problem is rather old, I've noticed that in 2.2, 2.4 and 2.5

dig1.png (26.4 KB) Jakub Kosik, 2014-07-26 04:40 AM

dig2.png (28.2 KB) Jakub Kosik, 2014-07-26 04:40 AM

dig3.png (150 KB) Jakub Kosik, 2014-07-26 04:40 AM

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Feedback

a few screenshot do not help understand well how to replicate this issue. What would be needed is a sample project and data (with the snapping options already defined as necessary) and/or a screencast (to help understand at what scale are you working, what steps to make, etc.).

#2 Updated by Jakub Kosik about 6 years ago

I cannot share this data due to law restrictions. I'll try to create some screencast. Now I'm collecting data outdoors with QGIS and Windows-tablet

#3 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF