Bug report #10903

Selecting many features in PostGIS layer leads to PostgreSQL crash

Added by Milos Kroulik almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19267

Description

When I tried to select all features in large PostGIS layer (definition in attachment), I experienced crash of PostgreSQL (as documented in the screenshot). It seems to be memory-related, as selecting only some of the features works as expected.

Software used was:
  • Debian 3.2.46-1+deb7u1 x86_64
  • PostgreSQL 9.4
  • PostGIS 2.1

Please let me know, if you need more info.

screen_015.png (212 KB) Milos Kroulik, 2014-07-16 06:46 AM

liniove_komunikace_static_map_for_debug.sql (9.26 KB) Milos Kroulik, 2014-07-16 06:46 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Category set to Vectors

the sql file does not contain any data, and does not seems to be possible to use it to restore the table in any other db.

Does the issue shows with any other large table? any type of geometry or just a specific one? how many features should we select to replicate the issue? How to select, manually from map canvas? from table of attributes? with an expression?

#2 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Feedback to Closed

If PostgreSQL crashes please file a bug on the PostgreSQL issue tracker or provide information about what QGIS needs to change if there is a good reason to do so.

Also available in: Atom PDF