Bug report #1084

ECW takes a long time to display

Added by William Kyngesburye over 13 years ago. Updated over 13 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11144

Description

In 0.9.1 ECW display is instantaneous, no matter how large the ECW was, probably because it used the inherent overviews. In 0.10.0 ECW takes a lot longer to display.

As a example, any of the Blue Marble ECW images takes about a minute before anything is displayed, during this time there is a lot of disk read activity. I gave up waiting for the Landsat742 ECW to display. I hadn't tried until now, but it's the same with 0.9.2rc1. I wonder if Qgis is not reading the overviews now?

I don't have a large JP2 to try, but I wonder if they have the same problem, since both ECW and JP2 have inherent overviews.

OSX 10.5.2, GDAL 1.5.1.

History

#1 Updated by ersts - over 13 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

This effectively a duplicate of ticket #778 and this issue this was addressed in ce7c48f9 (SVN r8399).

#2 Updated by William Kyngesburye over 13 years ago

Ah, my brain's pattern-matching missed this as I scanned the full bug list ;) Bummer that I have to open a raster first to set this option...

Also available in: Atom PDF