Bug report #10785

OpenStreetMap Export topology to Spatialite - export to polygons not working

Added by baditaflorin - over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19166

Description

I have imported a 400 mb osm file that i have get from JOSM Overpass API, and i try to export the polygons, but it does not get exported, i end up only with one result.

i tried with the points and the points get exported ok

exportbox.jpg (37.2 KB) baditaflorin -, 2014-07-02 06:18 PM

only2result.jpg (113 KB) baditaflorin -, 2014-07-02 06:18 PM

points.jpg (198 KB) baditaflorin -, 2014-07-02 06:18 PM

thesame.jpg (125 KB) baditaflorin -, 2014-07-03 02:16 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

if you are using 2.2 like in the other osm related ticket, please test 2.4 and see if it is confirmed.

#2 Updated by baditaflorin - over 7 years ago

i get the same result,only one polygon

If you want the same file that i am using, you can overpass and get the file in about one hour

[timeout:86400];
(node(34.759984,-12.216797,71.587596,36.298828)[shop];
way(34.759984,-12.216797,71.587596,36.298828)[shop];);
out meta;

#3 Updated by Giovanni Manghi over 7 years ago

baditaflorin - wrote:

i get the same result,only one polygon

If you want the same file that i am using, you can overpass and get the file in about one hour

maybe you can drop(box) it somewhere?

#5 Updated by Giovanni Manghi over 7 years ago

  • Operating System deleted (Windows)
  • OS version deleted (7)

confirmed on Linux too.

#6 Updated by baditaflorin - over 7 years ago

  • Status changed from Feedback to Closed

it was because of the query to overpass api, now is working https://github.com/drolbr/Overpass-API/issues/119#issuecomment-48021848

Also available in: Atom PDF