Bug report #10784

topology errors when digitizing

Added by Thomas Nogatz almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Digitising
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:19165

Description

new description (google translate):

When you are digitizing seamlessly abutting polygons produced QGIS 2.2 despite any set and functioning snap options (Snap Tolerance 10 pixels) often topological errors. The bases of the polygons are then obviously not exactly one above the other. The differences are tiny and not visible on the screen. However, a subsequent examination topology determines these errors that I've repaired through import and export via a Geodatabase with ArcGIS. QGIS 2.4 unfortunately I could not test, but wanted to do for lack of time to talk attention to this matter.


Beim Digitalisieren von nahtlos aneinander liegenden Polygonen produziert QGIS 2.2 trotz eingestellter und funktionierender Fangoptionen (Fangtoleranz 10 Pixel) oftmals topologische Fehler. Die Stützpunkte der Polygone liegen dann offensichtlich nicht ganz genau übereinander. Die Abweichungen sind winzig und auf dem Bildschirm nicht sichtbar. Eine anschließende Topologieprüfung ermittelt jedoch diese Fehler, die ich bisher durch Im- und Export über eine Geodatenbank mit ArcGIS repariert habe. QGIS 2.4 konnte ich leider noch nicht testen, wollte aber aus Zeitgründen schon mal auf diese Sache aufmerksam machen.

Viele Grüße und besten Dank an das QGIS-Team für diese großartige Software
Thomas

History

#1 Updated by Jürgen Fischer almost 6 years ago

please file tickets in English.

#2 Updated by Giovanni Manghi almost 6 years ago

  • Affected QGIS version changed from 2.4.0 to 2.2.0
  • Subject changed from Digitalisieren to topology errors when digitizing
  • Status changed from Open to Feedback

If I have understand well the automatic translation: this was a known issue that was supposedly solved but I'm not sure if it was before 2.2 or not.

Please try again on 2.4 and report back.

#3 Updated by Giovanni Manghi over 5 years ago

I tested after looking the notes in the old tickets about this issue, and it seems ok to me on 2.4

#4 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

closing for lack of feedback, please reopen if necessary.

#5 Updated by Thomas Nogatz over 5 years ago

  • Status changed from Closed to Reopened
  • Assignee set to Giovanni Manghi
  • % Done changed from 0 to 100

Hi Giovanni, sorry for late answer - I've been on the road until now, mostly without internet. Digitizing works well on 2.4 - Thank you very much! Regards Thomas

#6 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF