Bug report #10767

Simplified rendering causing boxes to appear instead

Added by Casper Børgesen over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Alvaro Huarte
Category:Simplification
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19149

Description

When using simplified rendering on a layer, I frequently get what seems like a bounding box instead of the correct underlying geometry.

I have created a data set with two polygons. When viewing at zoom level 1:5,000 the geometry looks okay, at 1:10,000 it shows boxes instead.

test.shx (116 Bytes) Casper Børgesen, 2014-07-01 06:23 AM

zoom_1_5000.JPG (13.1 KB) Casper Børgesen, 2014-07-01 06:23 AM

zoom_1_10000.JPG (9.29 KB) Casper Børgesen, 2014-07-01 06:23 AM

test.dbf (87 Bytes) Casper Børgesen, 2014-07-01 06:23 AM

test.prj (388 Bytes) Casper Børgesen, 2014-07-01 06:23 AM

test.shp (1.3 KB) Casper Børgesen, 2014-07-01 06:23 AM

Issue10767_beforePatch.JPG (65.1 KB) Alvaro Huarte, 2014-09-14 01:41 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Category set to Simplification
  • OS version deleted (7 64bit)
  • Operating System deleted (windows)
  • Target version set to Future Release - High Priority
  • Assignee set to Alvaro Huarte

confirmed also here on Linux with the lowest value for simplification.

#2 Updated by Alvaro Huarte over 5 years ago

  • Pull Request or Patch supplied changed from No to Yes

Hi, the PR ( https://github.com/qgis/QGIS/pull/1509 ) fixes this bug.

Best Regards

#3 Updated by Martin Dobias about 5 years ago

Hmm... I have just tested with latest master and I cannot replicate the problem anymore (with the given shapefile). What about others - do you still see the problem?

#4 Updated by Alvaro Huarte about 5 years ago

Hi Martin, the problem is there. The simplification logic has not changed from this PR was implemented.

The image shows the map with the geometries as lines when the geometries would be painted as boxes.

Best regards,
Alvaro

#5 Updated by Alvaro Huarte about 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in commit:

#eaacb125c402cf22dd66482b313bdaef73791fea

Also available in: Atom PDF