Bug report #10749

GPS tools fails to import

Added by David Lovelace over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:C++ plugins/GPS plugin
Affected QGIS version:2.4.0 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:19133

Description

The GPS tools option in vector crashes QGIS2.4 when trying to import waypoints from GPS unit (Garmin60sx). This is the same behaviour as with 2.2. The GPS unit is recognized by QGIS as is the port (USB) but immediately freezes on attempt to import or refresh. The session is then lost and QGIS has to be killed. The GPS waypoints import OK into stand-alone GPSBabel but QGIS should be able to import directly with the GPS Tools option “download from GPS”.

QGIS24_crashonGPSimport.jpg - screen shot of GPS tools dialog in action and QGIS freezing (200 KB) David Lovelace, 2014-06-29 05:49 AM

History

#1 Updated by Jürgen Fischer over 7 years ago

  • Category changed from Vectors to C++ Plugins

#2 Updated by Jürgen Fischer over 7 years ago

  • Category changed from C++ Plugins to C++ plugins/GPS plugin

#3 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #7182

As there is no one maintaining this tool I guess that this is a candidate of removal from QGIS (as SPIT and other tools), so keeping tickets open does not make much sense. Now there is also much less necessity of a tool to download waypoints from a gps unit as any recent gps unit has sd cards.

Also available in: Atom PDF