Bug report #1071

units conversion bogus for meters <-> feet

Added by bgullatt - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:11131

Description

Formating - When value crosses 1000 justification jumps to left.

Conversion - When you change map units in project properties there is no conversion just changes the unit text. If you change from meters to feet for instance it will show 1 mile at 1000 feet.

Related to #1024

History

#1 Updated by Maciej Sieczka - about 12 years ago

I can't reproduce the problem with formatting in 0.11 on GNU/Linux or Windows XP.

But the second issue still takes place, at least partially, both on Windows and GNU/Linux. Miles <-> kilometers transformation is OK, however if you zoom in so that hundreds of meters are displayed instead of kilometers, and change the project units, QGIS will claim that e.g. 200 m=200 feet. Easy to verify using map scale plugin.

#2 Updated by Magnus Homann about 12 years ago

This is the intended behaviour. The setting reflects what base unit is used, e.g the distance between (0,10) and (10,10) is set at 10 meter or 10 feet.

#3 Updated by Magnus Homann almost 12 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF