Bug report #10668

raster layer transparency 'no data value' checkbox is ignored - issue #10236 bug fix failed

Added by Tom Grundy over 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Rasters
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19067

Description

related to issue #10236 - the bug fix seems to be broken - it now (build commit.ca6d4d49 - should I get the latest to see if there have been any further changes?) 'remembers' the checkbox setting itself (on or off) as part of the saved project, but, now the checkbox value has no effect - it is always treated as if the checkbox is on and data value zero is always treated as transparent. I need data value zero to be opaque black. A workaround would probably be to remap the pixel values in a separate drawing tool, but that seems like a fairly circuitous workaround when dealing with several raster files.


Related issues

Duplicates QGIS Application - Bug report #10236: layer transparency 'no data value' checkbox setting is no... Closed 2014-05-12

History

#1 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF