Bug report #10608

not possible to insert a new column attribute table

Added by Claas Leiner over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Attribute table
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19012

Description

It is not possible to insert a new column in the attribute table of a shapefile with "add
Attribute". I can do it with the FieldCalculator!

Associated revisions

Revision c27e731e
Added by Martin Dobias over 6 years ago

Fix #10608 (impossible to add a new column in attribute table)

History

#1 Updated by Martin Dobias over 6 years ago

  • Assignee set to Martin Dobias

#2 Updated by Pedro Venâncio over 6 years ago

  • Assignee deleted (Martin Dobias)

I confirm this, but it affects all forms of creating new fields in the attributes table of shapefiles, as follows:

- Layer Properties:
I can only create (New column) fields of type "date". For all other types (integer, real, string), I get this error:
Name conflict: The attribute could not be inserted. The name already exists in the table.
(Note: Obviously there is no field with the same name I'm assigning).

- Attribute Table:
I can only create (New column) fields of type "integer" and "date". For "real" or "string", I get this error:
Attribute Error: The attribute could not be added to the layer

- Field Calculator:
I can only create (Create a new field) fields of type "date". For all other types (integer, real, string), I get this error:
Provider error: Could not add the new field to the provider.

With PostGIS data, everything works fine.

Tested on Windows 7 (64bits), with QGIS master 2.3.0-105 (OSGeo4W 64bits).

#3 Updated by Martin Dobias over 6 years ago

  • Status changed from Open to Closed

#4 Updated by Pedro Venâncio over 6 years ago

  • Assignee set to Martin Dobias

Pedro Venâncio wrote:

I confirm this, but it affects all forms of creating new fields in the attributes table of shapefiles, as follows:

- Layer Properties:
I can only create (New column) fields of type "date". For all other types (integer, real, string), I get this error:
Name conflict: The attribute could not be inserted. The name already exists in the table.
(Note: Obviously there is no field with the same name I'm assigning).

- Attribute Table:
I can only create (New column) fields of type "integer" and "date". For "real" or "string", I get this error:
Attribute Error: The attribute could not be added to the layer

- Field Calculator:
I can only create (Create a new field) fields of type "date". For all other types (integer, real, string), I get this error:
Provider error: Could not add the new field to the provider.

With PostGIS data, everything works fine.

Tested on Windows 7 (64bits), with QGIS master 2.3.0-105 (OSGeo4W 64bits).

#5 Updated by Pedro Venâncio over 6 years ago

Sorry Martin,

I was writing in the ticket and meanwhile you assigned it to yourself. However when I submitted, it blacked out.

Anyway, I added some information, indicating the different tools affected by the creation fields problem.

Your changes fixes everything, right?

Thank you very much Martin!

#6 Updated by Martin Dobias over 6 years ago

No problem... yeah I think the fix should cover all the cases

#7 Updated by Pedro Venâncio over 6 years ago

I confirm. Fixed for all cases!

Thank you very much Martin!

Also available in: Atom PDF