Bug report #10567

ERROR in attributes cells in spatialite layer table

Added by enrico ferreguti almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/SpatiaLite
Affected QGIS version:2.2.0 Regression?:No
Operating System:windows xp Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18974

Description

When I load a spatialite view as layer I see it right on map and I can get info, but when I open the attributes table I get always ERROR values. The view was create with Qspatialite plugin.

issue.jpg (327 KB) enrico ferreguti, 2014-06-12 07:42 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Category set to Data Provider/SpatiaLite

it is a plugin or QGIS issue? what happens if you create the view in DB manager? or from the SL command line? or SL gui?

#2 Updated by Antonio Locandro over 5 years ago

Having the same issue, it is a QGIS issue as I used the spatialite icon to add the layer. I created the view outside of QGIS directly using spatialite_gui so this means the problem is within QGIS.

When you use the identify results button you get the table information but if you open the attribute table what you get is ERROR in all the cells.

When I try to select one single feature from the view using the select tool all the features get selected, so this may be also related to this issue.

#3 Updated by Giovanni Manghi over 5 years ago

Antonio Locandro wrote:

Having the same issue, it is a QGIS issue as I used the spatialite icon to add the layer. I created the view outside of QGIS directly using spatialite_gui so this means the problem is within QGIS.

When you use the identify results button you get the table information but if you open the attribute table what you get is ERROR in all the cells.

When I try to select one single feature from the view using the select tool all the features get selected, so this may be also related to this issue.

I have just tested on QGIS 2.4 on Linux and I can't replicate the same issue. I used a SL database created empty in QGIS 2.4 and imported a shapefile in it with DB manager. The view then was done using spatialite_gui.

Please attach the SL db that contains the layer and the view.

#4 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF