Bug report #10498

Better resize the width of textbox and title in Properties of items in Print Composer (need by some languages)

Added by Harrissou Santanna over 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18908

Description

Hi,
The title of some options in the Print Composer is displayed on two lines instead of one.

In French for instance, the attached file shows the properties of a legend in Map composer.
The title of certain options cannot hold on a line. They are then presented on two lines, not always readable. One can think that widen the frame should solve the problem but when you do so, only the space dedicated to the values widen itself. It looks like if in the current configuration, the title has its width (blocked) and the text box gets the rest of space (depending on how wide is the "Properties" tab).

IMHO, This is not a good option especially as the contents of these text boxes are widely lower than 10 characters. we know that, we know their limits but we don't know how many characters will require the translation of the title in another language.
I think that, by default, text boxes should have a minimum width (let's say the space needed by 10 characters) and their title should be as large as possible (so that all languages (or most of them) could have their title hold on one line).

Then, when the user resizes the tab, only the text box can be widened (as it is done now). We'd already ensured the user will read all the title.

TextPptesLegend.png (29.9 KB) Harrissou Santanna, 2014-06-08 07:22 AM

Associated revisions

Revision 7840dbe3
Added by Matthias Kuhn almost 4 years ago

Do not wrap labels in composer legend properties widget

Fix #10498

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#2 Updated by Harrissou Santanna almost 5 years ago

Hi,
There is a proposal of fix here

#3 Updated by Giovanni Manghi almost 5 years ago

  • Pull Request or Patch supplied changed from No to Yes

#4 Updated by Harrissou Santanna over 4 years ago

Hi,
Can someone review and tell if this is the way this bug should be fixed, please? The GUI is not really readable for localized QGIS

#5 Updated by Anonymous almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF