Bug report #10493

Todays build crashes when loading a map

Added by Tobias Schneider almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:18904

Description

Since todays build, every time I load a map QGIS crashes. The console tells me this on startup:

Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
Warning: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Toolbox" under id 256

and this after loading the map:

QGIS died on signal 11Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Die Operation ist nicht erlaubt.
No thread selected
No stack.
gdb returned 0
Abgebrochen (Speicherabzug geschrieben)

System: ubuntu 14.04 64 bit

History

#1 Updated by Tobias Schneider almost 10 years ago

New build does similar bad:

Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
Warning: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Toolbox" under id 256
ERROR 1: Attempt to read shape with feature id (3), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (6), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (7), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (8), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (14), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (15), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (16), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (18), but it is marked deleted.
Warning 1: organizePolygons() received an unexpected geometry.
Either a polygon with interior rings, or a polygon with less than 4 points,
or a non-Polygon geometry. Return arguments as a collection.
ERROR 1: Attempt to read shape with feature id (3), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (6), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (7), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (8), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (14), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (15), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (16), but it is marked deleted.
ERROR 1: Attempt to read shape with feature id (18), but it is marked deleted.
Warning 1: organizePolygons() received an unexpected geometry.
Either a polygon with interior rings, or a polygon with less than 4 points,
or a non-Polygon geometry. Return arguments as a collection.
ERROR 1: IllegalArgumentException: Invalid number of points in LinearRing found 3 - must be 0 or >= 4
Warning 1: organizePolygons() received an unexpected geometry.
Either a polygon with interior rings, or a polygon with less than 4 points,
or a non-Polygon geometry. Return arguments as a collection.
QGIS died on signal 11Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Die Operation ist nicht erlaubt.
No thread selected
No stack.
gdb returned 0
Abgebrochen (Speicherabzug geschrieben)

#2 Updated by Giovanni Manghi almost 10 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High

does happen loading any project or layer? How did you installed, using the nightly-build repo (with or without ubuntugis?) or compiling?

#3 Updated by Giovanni Manghi almost 10 years ago

  • Status changed from Open to Feedback

#4 Updated by Tobias Schneider almost 10 years ago

  • Status changed from Feedback to Closed

I can't reproduce the bug in today's build. It only happened with vector and postgis layers (not raster layers) yesterday. I use the nightly build from http://qgis.org/debian-nightly - I think we can close this now.

Also available in: Atom PDF